using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)\s*(ml|gm?|kg|cm)\b";
string input = @"Rexona Ap Deo Aerosol 150ml Active CPD-05923
Cutex Nail Polish Remover Moisture 100ml";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}