re = /\b(\d+)\s*(ml|gm?|kg|cm)\b/
str = 'Rexona Ap Deo Aerosol 150ml Active CPD-05923
Cutex Nail Polish Remover Moisture 100ml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end