package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\d+)\s*(ml|gm?|kg|cm)\b`)
var str = `Rexona Ap Deo Aerosol 150ml Active CPD-05923
Cutex Nail Polish Remover Moisture 100ml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}