// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(\d+)\s*(ml|gm?|kg|cm)\b").unwrap();
let string = "Rexona Ap Deo Aerosol 150ml Active CPD-05923
Cutex Nail Polish Remover Moisture 100ml";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}