use strict;
my $str = 'cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF
cn=CCCC,ou=Profils,o=SF';
my $regex = qr/\bcn=([A-Z]{4})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}