$re = '/\bcn=([A-Z]{4})\b/m';
$str = 'cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF
cn=CCCC,ou=Profils,o=SF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);