// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bcn=([A-Z]{4})\b").unwrap();
let string = "cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF
cn=CCCC,ou=Profils,o=SF";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}