re = /\bcn=([A-Z]{4})\b/m
str = 'cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF
cn=CCCC,ou=Profils,o=SF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end