#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][\s\S]*?[.!?](?:\n\n|\z)"
Local $sString = "This is a test! I would like to ensure the first character is a capital and the last is a punctuation with anything in between." & @CRLF & _
"" & @CRLF & _
"This is a test. " & @CRLF & _
"I would like to ensure the first character is a capital and the last is a punctuation with anything in between." & @CRLF & _
"" & @CRLF & _
"This is a test. I would like to ensure the first character is a capital and the last is a punctuation with anything in between."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")