re = /^[A-Z][\s\S]*?[.!?](?:\n\n|\z)/m
str = 'This is a test! I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test.
I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test. I would like to ensure the first character is a capital and the last is a punctuation with anything in between.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end