$re = '/^[A-Z][\s\S]*?[.!?](?:\n\n|\z)/m';
$str = 'This is a test! I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test.
I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test. I would like to ensure the first character is a capital and the last is a punctuation with anything in between.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);