import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][\\s\\S]*?[.!?](?:\\n\\n|\\z)";
final String string = "This is a test! I would like to ensure the first character is a capital and the last is a punctuation with anything in between.\n\n"
+ "This is a test. \n"
+ "I would like to ensure the first character is a capital and the last is a punctuation with anything in between.\n\n"
+ "This is a test. I would like to ensure the first character is a capital and the last is a punctuation with anything in between.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}