using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/[\w-]+(\.[\w-]+)*(:\d{1,5})?";
string input = @"http://www.memberpress.com
https://www.memberpress.com
http://localhost:3000
http://example123.com
hi there. what is up g?
Here's a phone number we don't want to match (888) 555-1111
/wp-content/uploads/10/1/cool.pdf
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}