$re = '/https?:\/\/[\w-]+(\.[\w-]+)*(:\d{1,5})?/';
$str = 'http://www.memberpress.com
https://www.memberpress.com
http://localhost:3000
http://example123.com
hi there. what is up g?
Here\'s a phone number we don\'t want to match (888) 555-1111
/wp-content/uploads/10/1/cool.pdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);