const regex = /https?:\/\/[\w-]+(\.[\w-]+)*(:\d{1,5})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[\\w-]+(\\.[\\w-]+)*(:\\d{1,5})?', 'g')
const str = `http://www.memberpress.com
https://www.memberpress.com
http://localhost:3000
http://example123.com
hi there. what is up g?
Here's a phone number we don't want to match (888) 555-1111
/wp-content/uploads/10/1/cool.pdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}