using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"D\[(.*?)\]";
string input = @"D[date-string] T[time-string] N[name-string] M[message-string]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}