re = /D\[(.*?)\]/
str = 'D[date-string] T[time-string] N[name-string] M[message-string]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end