$re = '/D\[(.*?)\]/';
$str = 'D[date-string] T[time-string] N[name-string] M[message-string]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);