#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?:\/\/)?(www\.)?([\w]+\.)+[\w]{2,63}\/?$"
Local $sString = "http://google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"https://google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"www..com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")