$re = '/^(https?:\/\/)?(www\.)?([\w]+\.)+[\w]{2,63}\/?$/m';
$str = 'http://google.com
www.google.com
https://google.com
http://www.google.com
www..com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);