using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?:\/\/)?(www\.)?([\w]+\.)+[\w]{2,63}\/?$";
string input = @"http://google.com
www.google.com
https://google.com
http://www.google.com
www..com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}