import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?\\bfruits\\b.*?)$[\\S\\s]+?(?=\\borange\\b)[\\S\\s]*?\\n[^ ]";
final String string = "my colors\n"
+ " i am red\n"
+ " i am blue\n"
+ " i am green\n\n"
+ "my fruits\n"
+ " abc\n"
+ " def\n"
+ " i am a apple\n"
+ " i am a orange\n"
+ " i am a banana\n"
+ " \n\n"
+ "my vehicle\n"
+ " i am a sedan\n"
+ " i am a van\n"
+ " i am a motorbike";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}