import re
regex = re.compile(r"^(.*?\bfruits\b.*?)$[\S\s]+?(?=\borange\b)[\S\s]*?\n[^ ]", flags=re.MULTILINE)
test_str = ("my colors\n"
" i am red\n"
" i am blue\n"
" i am green\n\n"
"my fruits\n"
" abc\n"
" def\n"
" i am a apple\n"
" i am a orange\n"
" i am a banana\n"
" \n\n"
"my vehicle\n"
" i am a sedan\n"
" i am a van\n"
" i am a motorbike")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")