const regex = new RegExp('^(.*?\\bfruits\\b.*?)$[\\S\\s]+?(?=\\borange\\b)[\\S\\s]*?\\n[^ ]', 'gm')
const str = `my colors
i am red
i am blue
i am green
my fruits
abc
def
i am a apple
i am a orange
i am a banana
my vehicle
i am a sedan
i am a van
i am a motorbike`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}