re = /^(.*?\bfruits\b.*?)$[\S\s]+?(?=\borange\b)[\S\s]*?\n[^ ]/m
str = 'my colors
i am red
i am blue
i am green
my fruits
abc
def
i am a apple
i am a orange
i am a banana
my vehicle
i am a sedan
i am a van
i am a motorbike'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end