# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)$/<p>\1<\/p>/gm;t' <<< "Paragraph 1
paragraph 2"