$re = '/^(.+)$/m';
$str = 'Paragraph 1
paragraph 2';
$subst = "<p>\1</p>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;