use strict;
my $str = 'Paragraph 1
paragraph 2';
my $regex = qr/^(.+)$/mp;
my $subst = '<p>\\1</p>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";