import re
regex = re.compile(r"(((max-age=\d+)|(pin-sha256=\"[\d\w]+=?=?\"));\s{0,1})+includeSubDomains", flags=re.IGNORECASE)
test_str = "pin-sha256=\"WoiWRyIOVNa9ihaBciRSC7XHjliYS9VwUGOIud4PB18=\"; pin-sha256=\"JbQbUG5JMJUoI6brnx0x3vZF6jilxsapbXGVfjhN8Fg=\"; max-age=300; includeSubDomains"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")