const regex = /.*?\)\s*(.*?)\s*\(.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?\\)\\s*(.*?)\\s*\\(.*', '')
const str = `- (!!) reply to emails (Today)
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);