re = /.*?\)\s*(.*?)\s*\(.*/
str = '- (!!) reply to emails (Today)
'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result