import re
regex = re.compile(r".*?\)\s*(.*?)\s*\(.*")
test_str = ("- (!!) reply to emails (Today)\n")
subst = "\\1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)