use strict;
my $str = '- (!!) reply to emails (Today)
';
my $regex = qr/.*?\)\s*(.*?)\s*\(.*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";