using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\starttable[\s\S]*?\HL[\s\S]*?\HL";
string input = @"\starttable[|lp(0.08\textwidth)|lp(0.35\textwidth)|lp(0.48\textwidth)|lp(0.08\textwidth)|]
\HL
\NC Req. Id
\NC Description
\NC Test Scenario
\NC Result
\NC\AR
\HL
\NC TAF-89
\NC Trigger test start - from jig
\NC
\NC Unavailable
\NC\AR
\NC TAF-88
\NC Trigger test start - using scanner
\NC
\NC Unavailable
\NC\AR
\HL";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}