import Foundation
let pattern = #"\\starttable[\s\S]*?\HL[\s\S]*?\HL"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\starttable[|lp(0.08\textwidth)|lp(0.35\textwidth)|lp(0.48\textwidth)|lp(0.08\textwidth)|]
\HL
\NC Req. Id
\NC Description
\NC Test Scenario
\NC Result
\NC\AR
\HL
\NC TAF-89
\NC Trigger test start - from jig
\NC
\NC Unavailable
\NC\AR
\NC TAF-88
\NC Trigger test start - using scanner
\NC
\NC Unavailable
\NC\AR
\HL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)