const regex = /\\starttable[\s\S]*?\HL[\s\S]*?\HL/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\starttable[\\s\\S]*?\\HL[\\s\\S]*?\\HL', 'g')
const str = `\\starttable[|lp(0.08\\textwidth)|lp(0.35\\textwidth)|lp(0.48\\textwidth)|lp(0.08\\textwidth)|]
\\HL
\\NC Req. Id
\\NC Description
\\NC Test Scenario
\\NC Result
\\NC\\AR
\\HL
\\NC TAF-89
\\NC Trigger test start - from jig
\\NC
\\NC Unavailable
\\NC\\AR
\\NC TAF-88
\\NC Trigger test start - using scanner
\\NC
\\NC Unavailable
\\NC\\AR
\\HL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}