re = /\\starttable[\s\S]*?\HL[\s\S]*?\HL/
str = '\\starttable[|lp(0.08\\textwidth)|lp(0.35\\textwidth)|lp(0.48\\textwidth)|lp(0.08\\textwidth)|]
\\HL
\\NC Req. Id
\\NC Description
\\NC Test Scenario
\\NC Result
\\NC\\AR
\\HL
\\NC TAF-89
\\NC Trigger test start - from jig
\\NC
\\NC Unavailable
\\NC\\AR
\\NC TAF-88
\\NC Trigger test start - using scanner
\\NC
\\NC Unavailable
\\NC\\AR
\\HL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end