#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[Chorus:[^\]]+\][\s\S]*?(?=\n{2}|$)"
Local $sString = "[Chorus: x2]" & @CRLF & _
"Some Lyrics" & @CRLF & _
"Some More Lyrics" & @CRLF & _
"" & @CRLF & _
"[Verse]" & @CRLF & _
"Lyrics" & @CRLF & _
"Lyrics"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")