import re
regex = re.compile(r"\[Chorus:[^\]]+\][\s\S]*?(?=\n{2}|$)")
test_str = ("[Chorus: x2]\n"
"Some Lyrics\n"
"Some More Lyrics\n\n"
"[Verse]\n"
"Lyrics\n"
"Lyrics")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")