using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[Chorus:[^\]]+\][\s\S]*?(?=\n{2}|$)";
string input = @"[Chorus: x2]
Some Lyrics
Some More Lyrics
[Verse]
Lyrics
Lyrics";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}