$re = '/\[Chorus:[^\]]+\][\s\S]*?(?=\n{2}|$)/';
$str = '[Chorus: x2]
Some Lyrics
Some More Lyrics
[Verse]
Lyrics
Lyrics';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);