#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<ModelCode>\w{1})\((?<CountryCode>\w{3,4})\)\-(?<ModelNumber>\w{2})(\-(?<StackerType>\w{2}))? (?<InterfaceType>ID003\-\d{2})v(?<SoftwareVersion>\d{3}\-\d{2}) (?<SotfwareDate>\w+) (?<Crc>\w{4})"
Local $sString = "P(EUR)-07 ID003-04V201-63 08JUN10 14C0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")