import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ModelCode>\\w{1})\\((?<CountryCode>\\w{3,4})\\)\\-(?<ModelNumber>\\w{2})(\\-(?<StackerType>\\w{2}))? (?<InterfaceType>ID003\\-\\d{2})v(?<SoftwareVersion>\\d{3}\\-\\d{2}) (?<SotfwareDate>\\w+) (?<Crc>\\w{4})";
final String string = "P(EUR)-07 ID003-04V201-63 08JUN10 14C0";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}