import re
regex = re.compile(r"(?<ModelCode>\w{1})\((?<CountryCode>\w{3,4})\)\-(?<ModelNumber>\w{2})(\-(?<StackerType>\w{2}))? (?<InterfaceType>ID003\-\d{2})v(?<SoftwareVersion>\d{3}\-\d{2}) (?<SotfwareDate>\w+) (?<Crc>\w{4})", flags=re.IGNORECASE)
test_str = "P(EUR)-07 ID003-04V201-63 08JUN10 14C0"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")