import Foundation
let pattern = #"(?<ModelCode>\w{1})\((?<CountryCode>\w{3,4})\)\-(?<ModelNumber>\w{2})(\-(?<StackerType>\w{2}))? (?<InterfaceType>ID003\-\d{2})v(?<SoftwareVersion>\d{3}\-\d{2}) (?<SotfwareDate>\w+) (?<Crc>\w{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"P(EUR)-07 ID003-04V201-63 08JUN10 14C0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}