#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)[\w,=/:.-]+\.(?:jpe?g|png|gif)"
Local $sString = "<a href="https://e...content-available-to-author-only...e.com/example1.jpg">" & @CRLF & _
"<a href="https://e...content-available-to-author-only...e.com/ストスト.jpg">" & @CRLF & _
"<a href="https://e...content-available-to-author-only...e.com/example3.jpg "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")