// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)[\w,=/:.-]+\.(?:jpe?g|png|gif)").unwrap();
let string = "<a href=\"https://e...content-available-to-author-only...e.com/example1.jpg\">
<a href=\"https://e...content-available-to-author-only...e.com/ストスト.jpg\">
<a href=\"https://e...content-available-to-author-only...e.com/example3.jpg ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}