using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w,=/:.-]+\.(?:jpe?g|png|gif)";
string input = @"<a href=""https://e...content-available-to-author-only...e.com/example1.jpg"">
<a href=""https://e...content-available-to-author-only...e.com/ストスト.jpg"">
<a href=""https://e...content-available-to-author-only...e.com/example3.jpg ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}