package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w,=/:.-]+\.(?:jpe?g|png|gif)`)
var str = `<a href="https://e...content-available-to-author-only...e.com/example1.jpg">
<a href="https://e...content-available-to-author-only...e.com/ストスト.jpg">
<a href="https://e...content-available-to-author-only...e.com/example3.jpg `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}