package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|[1-5][0-9]|60(\.0{1,2})?$)(\.[0-9]{1,2})?$`)
var str = `0
0.01
1
1.0
9
10
19
20
21
21.23
21.234
29
30
31
39
40
41
49
50
53
59
60
60.00
60.01
61`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}